Browse Source

Fix crypto/des/build.info

!$disabled{mdc2} was used to determine if DES files should be included
in providers/liblegacy.a.  Use !$disabled{des} instead.

Fixes #13865

Reviewed-by: Matt Caswell <matt@openssl.org>
(Merged from https://github.com/openssl/openssl/pull/13866)
master
Richard Levitte 1 year ago
parent
commit
3f6e891d42
1 changed files with 1 additions and 1 deletions
  1. +1
    -1
      crypto/des/build.info

+ 1
- 1
crypto/des/build.info View File

@ -31,7 +31,7 @@ DEFINE[../../providers/liblegacy.a]=$DESDEF
# When all deprecated symbols are removed, libcrypto doesn't export the
# DES functions, so we must include them directly in liblegacy.a
IF[{- $disabled{'deprecated-3.0'} && !$disabled{"mdc2"} -}]
IF[{- $disabled{'deprecated-3.0'} && !$disabled{des} -}]
SOURCE[../../providers/liblegacy.a]=$ALL
DEFINE[../../providers/liblegacy.a]=$DESDEF
ENDIF


Loading…
Cancel
Save