Browse Source

dasync is an internal testing engine, so don't install it

Unfortunately, it means that the VMS IVP gets a bit crippled.  This
will be fixed later on.

Reviewed-by: Matt Caswell <matt@openssl.org>
master
Richard Levitte 6 years ago
parent
commit
46117d31fe
2 changed files with 6 additions and 6 deletions
  1. +2
    -2
      VMS/openssl_ivp.com.in
  2. +4
    -4
      engines/build.info

+ 2
- 2
VMS/openssl_ivp.com.in View File

@ -38,8 +38,8 @@ $ ! If something else is wrong with the installation, we're likely
$ ! to get an image activation error here
$ openssl version -a
$
$ ! Verify that engines are where they should be.
$ openssl engine -c -t dasync
$ ! FUTURE ENHANCEMENT: Verify that engines are where they should be.
$ ! openssl engine -c -t checker
$
$ WRITE SYS$ERROR "OpenSSL IVP passed"
$ EXIT %x10000001


+ 4
- 4
engines/build.info View File

@ -2,14 +2,12 @@ IF[{- !$disabled{"engine"} -}]
IF[{- $disabled{"dynamic-engine"} -}]
LIBS=../libcrypto
SOURCE[../libcrypto]=\
e_padlock.c {- $target{padlock_asm_src} -} \
e_dasync.c
e_padlock.c {- $target{padlock_asm_src} -}
IF[{- !$disabled{capieng} -}]
SOURCE[../libcrypto]=e_capi.c
ENDIF
ELSE
ENGINES=padlock dasync
ENGINES_NO_INST=ossltest
ENGINES=padlock
SOURCE[padlock]=e_padlock.c {- $target{padlock_asm_src} -}
DEPEND[padlock]=../libcrypto
INCLUDE[padlock]=../include
@ -19,6 +17,8 @@ IF[{- !$disabled{"engine"} -}]
DEPEND[capi]=../libcrypto
INCLUDE[capi]=../include
ENDIF
ENGINES_NO_INST=ossltest dasync
SOURCE[dasync]=e_dasync.c
DEPEND[dasync]=../libcrypto
INCLUDE[dasync]=../include


Loading…
Cancel
Save