Use cargo and rustc 1.60 or later.

- Don't use the `rust-toolchain` file to specify the version of
    `cargo` and `rustc` to use.  Instead use `rust-version` in
    `Cargo.toml`.

  - Note: this changes how we choose the tool chain: `rust-version` is
    a minimal version; `rust-toolchain` is an exact version.

  - Use 1.60 as that is what is currently available in Debian testing.

  - Closes #7, #10.
pull/11/head
Neal Walfield 2 months ago
parent 32ff90c675
commit 87b6392ac9
No known key found for this signature in database
GPG Key ID: 6863C9AD5B4D22D3
  1. 4
      .gitlab-ci.yml
  2. 1
      Cargo.toml
  3. 2
      README.md
  4. 1
      rust-toolchain

@ -109,7 +109,6 @@ rust-stable-armv7:
before_script:
- *before_script_start
- cat .ci/snippet_for_cross_compilation_config.toml >> .cargo/config.toml
- rm rust-toolchain
- *before_script_end
script:
- cargo test
@ -195,8 +194,7 @@ windows-msvc-32:
before_script:
# We don't call *before_script_start or *before_script_end as we
# don't have bash, clang, etc.
- rm rust-toolchain
- rustup default 1.56.0-x86_64-pc-windows-msvc
- rustup default 1.60.0-x86_64-pc-windows-msvc
- rustup target add i686-pc-windows-msvc
- rustup show
- rustc --version --verbose

@ -10,6 +10,7 @@ keywords = ["cryptography", "openpgp", "pgp", "encryption", "signing"]
categories = ["cryptography", "authentication", "email"]
license = "GPL-3.0-or-later"
edition = "2018"
rust-version = "1.60"
[badges]
maintenance = { status = "actively-developed" }

@ -8,7 +8,7 @@ This library provides an implementation of the [p≡p Engine]'s
Building
========
You need at least version 1.48 of `rustc` and `cargo`.
You need at least version 1.60 of `rustc` and `cargo`.
You can build this library as follows:

@ -1 +0,0 @@
1.48.0
Loading…
Cancel
Save